登录 用户中心() [退出] 后台管理 注册
 

热门搜索:
您的位置: 首页 首页 >> iphone网页即移动端浏览器全覆盖开发专栏 >> iphone网页即移动端浏览器全覆盖开发专栏 >> 主题: 步骤8 -- Bootstrap 和 jquery 版本的选择 - 并不要选择最新的版本    [最新]
标题
步骤8 -- Bootstrap 和 jquery 版本的选择 - 并不要选择最新的版本
clq
浏览(575) - 2017-07-15 18:49:08 发表 编辑

关键字:

[2017-07-15 18:55:09 最后更新]
步骤8 -- Bootstrap 和 jquery 版本的选择 - 并不要选择最新的版本

Bootstrap 最新的版本目前是 4.0 应该是在 2015 年左右升级的,不过我个人并不赞成升级到这个版本. 因为 b4 不支持 ie8 及以下版本,等于完全放弃了 windows xp/2003 系统,
这在目前的国内肯定是不现实的,好在 Bootstrap 的团队知道这种状况, Bootstrap 3.0 仍然维护.

jquery 的情况与之类似,2016 后它升级到了 3.0 版本. 其实从 2.0 起它就不再支持 IE6/7/8, 调用上无区别, 兼容1.9的API, 内核发生了变化. 1.x分支会继续发展下去.
其实最新的 Bootstrap 用 jquery 1.9 就可以正常工作.

Bootstrap 升级还不好说什么,我们本来也主要是用它来开发手机版本; jquery 不支持 ie8 我就觉得很可笑,要知道 jquery 本来就是为了解决 ie 等浏览器的兼容性才诞生的.
不过 jquery 我们也只是主要使用它的选择器,它的那些插件不用也罢.

所以就目前来说我们使用 Bootstrap 3 + jquery 1.9 就好了. 它们都可以在各大网络巨头的分流服务器上直接引用,例如我们一直用的 baidu 的:

    <!-- 新 Bootstrap 核心 CSS 文件 -->
    <link href="http://apps.bdimg.com/libs/bootstrap/3.3.0/css/bootstrap.min.css" rel="stylesheet">
   
    <!-- 可选的Bootstrap主题文件(一般不使用) -->
    <script src="http://apps.bdimg.com/libs/bootstrap/3.3.0/css/bootstrap-theme.min.css"></script>
   
    <!-- jQuery文件。务必在bootstrap.min.js 之前引入 -->
    <script src="http://apps.bdimg.com/libs/jquery/2.0.0/jquery.min.js"></script>
    这两种地址目前都可以
    <script src="http://libs.baidu.com/jquery/1.11.1/jquery.min.js"></script>
   
    <!-- 最新的 Bootstrap 核心 JavaScript 文件 -->
    <script src="http://apps.bdimg.com/libs/bootstrap/3.3.0/js/bootstrap.min.js"></script>





clq
2017-07-15 18:55:08 发表 编辑

更多的地址可以用关键字 "常用的jQuery引用地址" 查询得到.

总数:1 页次:1/1 首页 尾页  
总数:1 页次:1/1 首页 尾页  


该采集也在以下书单中



发表评论:
文本/html模式切换 插入图片 文本/html模式切换


附件:



NEWBT官方QQ群1: 276678893
可求档连环画,漫画;询问文本处理大师等软件使用技巧;求档softhub软件下载及使用技巧.
但不可"开车",严禁国家敏感话题,不可求档涉及版权的文档软件.
验证问题说明申请入群原因即可.

Copyright © 2005-2017 clq, All Rights Reserved
CLQ工作室 版权所有